python-nuitka/PKGBUILD
2024-10-22 19:11:31 +08:00

30 lines
972 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=python-nuitka
pkgver=2.4.10
pkgrel=1
pkgdesc="Python compiler with full language support and CPython compatibility"
arch=('x86_64')
url="https://nuitka.net"
license=('Apache-2.0')
depends=('patchelf' 'python-ordered-set' 'python-zstandard' 'python')
makedepends=('python-build' 'python-installer' 'python-wheel' 'python-packaging')
source=(https://pypi.debian.net/Nuitka/Nuitka-${pkgver}.tar.gz)
sha256sums=(51f24c4dc6282225fbe601095d1a9ee1c9eda08207e8eeab63e64b1800659941)
build() {
cd Nuitka-${pkgver}
python3 -m build --wheel --no-isolation
}
package() {
cd Nuitka-${pkgver}
python3 -m installer --destdir=${pkgdir} dist/*.whl
}