30 lines
964 B
Bash
30 lines
964 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=python-patiencediff
|
|
pkgver=0.2.15
|
|
pkgrel=1
|
|
pkgdesc="Patiencediff Python and C implementations"
|
|
arch=('x86_64')
|
|
url="https://www.breezy-vcs.org"
|
|
license=('GPL2')
|
|
depends=('glibc' 'python')
|
|
makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
|
|
source=(https://github.com/breezy-team/patiencediff/archive/v${pkgver}/${pkgname#*-}-${pkgver}.tar.gz)
|
|
sha256sums=(77b905e2f02029244a46b99ac3682e4a50ccc2f7e0cc66c1a025282328647b5d)
|
|
|
|
build() {
|
|
cd ${pkgname#*-}-${pkgver}
|
|
|
|
python3 -m build --wheel --no-isolation
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname#*-}-${pkgver}
|
|
|
|
python3 -m installer --destdir=${pkgdir} dist/*.whl
|
|
}
|