python-pyalpm/PKGBUILD
2024-10-31 13:15:16 +08:00

26 lines
744 B
Bash

# Maintainer: Future Linux Team <futurelinux@163.com>
pkgname=python-pyalpm
pkgver=0.10.10
pkgrel=1
pkgdesc="Python 3 bindings for libalpm"
arch=('x86_64')
license=('GPL-3.0-or-later')
url="https://gitlab.archlinux.org/archlinux/pyalpm"
depends=('python' 'pacman')
makedepends=('python-setuptools' 'python-pkgconfig' 'python-build' 'python-installer' 'python-wheel')
source=(https://gitlab.archlinux.org/archlinux/pyalpm/-/archive/${pkgver}/${pkgname#*-}-${pkgver}.tar.gz)
sha256sums=(55f3efc36324c9bbffbaff5aa6424931ee101479a5b5655dc5983c6a7f3f1972)
build() {
cd ${pkgname#*-}-${pkgver}
python3 -m build --wheel --no-isolation
}
package() {
cd ${pkgname#*-}-${pkgver}
python3 -m installer --destdir=${pkgdir} dist/*.whl
}