27 lines
750 B
Bash
27 lines
750 B
Bash
# Maintainer: Future Linux Team <futurelinux@163.com>
|
|
|
|
pkgname=python-pyelftools
|
|
pkgver=0.31
|
|
pkgrel=1
|
|
pkgdesc="Python library for analyzing ELF files and DWARF debugging information"
|
|
arch=('x86_64')
|
|
url="https://github.com/eliben/pyelftools"
|
|
license=('custom:Public Domain')
|
|
depends=('python')
|
|
makedepends=('python-build' 'python-installer' 'python-wheel' 'python-setuptools')
|
|
options=('!strip')
|
|
source=(https://github.com/eliben/pyelftools/archive/v${pkgver}/${pkgname#*-}-${pkgver}.tar.gz)
|
|
sha256sums=(24815cbfff9c5f68f5268983f55d969540a087bfdaa73c93f1a88e2a771f80f1)
|
|
|
|
build() {
|
|
cd ${pkgname#*-}-${pkgver}
|
|
|
|
python3 -m build --wheel --no-isolation
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname#*-}-${pkgver}
|
|
|
|
python3 -m installer --destdir=${pkgdir} dist/*.whl
|
|
}
|