python-pyyaml/PKGBUILD
2024-10-30 00:20:00 +08:00

30 lines
1015 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=python-pyyaml
pkgver=6.0.2
pkgrel=1
pkgdesc="Python bindings for YAML, using fast libYAML library"
arch=('x86_64')
url="https://github.com/yaml/pyyaml"
license=('MIT')
depends=('glibc' 'libyaml' 'python')
makedepends=('python-cython' 'python-build' 'python-installer' 'python-setuptools' 'python-wheel')
source=(https://github.com/yaml/pyyaml/archive/${pkgver}/${pkgname#*-}-${pkgver}.tar.gz)
sha256sums=(9377c381ac3fccad8df73d96b5139ef8b1a2c57a0d913e95ab0a2275d66b5caa)
build() {
cd ${pkgname#*-}-${pkgver}
python3 -m build --wheel --no-isolation --config-setting=--with-libyaml
}
package() {
cd ${pkgname#*-}-${pkgver}
python3 -m installer --destdir=${pkgdir} dist/*.whl
}