36 lines
1008 B
Bash
36 lines
1008 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=python-setuptools-gettext
|
|
pkgver=0.1.14
|
|
pkgrel=1
|
|
pkgdesc="Setuptools plugin for building .mo files"
|
|
arch=('x86_64')
|
|
url="https://github.com/breezy-team/setuptools-gettext"
|
|
license=('GPL')
|
|
depends=('python' 'python-setuptools' 'python-tomli')
|
|
makedepends=('git' 'python-build' 'python-installer' 'python-wheel')
|
|
source=(git+https://github.com/breezy-team/setuptools-gettext.git#tag=0e9965aa50eeacd104f08124527b69e827048da6)
|
|
sha256sums=(SKIP)
|
|
|
|
pkgver() {
|
|
cd ${pkgname#*-}
|
|
|
|
git describe --tags | sed 's/^v//'
|
|
}
|
|
|
|
build() {
|
|
cd ${pkgname#*-}
|
|
|
|
python3 -m build --wheel --no-isolation
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname#*-}
|
|
|
|
python3 -m installer --destdir=${pkgdir} dist/*.whl
|
|
}
|