python-setuptools/PKGBUILD

31 lines
1021 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=python-setuptools
pkgver=69.2.0
pkgrel=1
pkgdesc="Easily download, build, install, upgrade, and uninstall Python packages"
arch=('x86_64')
url="https://pypi.org/project/setuptools/"
license=('PSF')
depends=('python')
makedepends=('python-flit-core' 'python-wheel' 'python-installer' 'python-build')
source=(https://github.com/pypa/setuptools/archive/${pkgver}/${pkgname#*-}-${pkgver}.tar.gz)
sha256sums=(a03e246286ffa56fd3f9a323d2642fe8a6c301341e3656981373e4807a5ea038)
build() {
cd ${pkgname#*-}-${pkgver}
python3 setup.py egg_info
python3 -m build --wheel --skip-dependency-check --no-isolation
}
package() {
cd ${pkgname#*-}-${pkgver}
python3 -m installer --destdir=${pkgdir} dist/*.whl
}