30 lines
1013 B
Bash
30 lines
1013 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=python-sphinxcontrib-applehelp
|
|
pkgver=2.0.0
|
|
pkgrel=1
|
|
pkgdesc="Sphinx extension which outputs Apple help books"
|
|
arch=('x86_64')
|
|
url="https://github.com/sphinx-doc/sphinxcontrib-applehelp"
|
|
license=('BSD-2-Clause')
|
|
depends=('python')
|
|
makedepends=('python-build' 'python-flit-core' 'python-installer')
|
|
source=(https://github.com/sphinx-doc/sphinxcontrib-applehelp/archive/${pkgver}/${pkgname#*-}-${pkgver}.tar.gz)
|
|
sha256sums=(953f2b79bf0162715e943fadbb805f614fb879c61f07a44d425961485baf7891)
|
|
|
|
build() {
|
|
cd ${pkgname#*-}-${pkgver}
|
|
|
|
python3 -m build --wheel --skip-dependency-check --no-isolation
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname#*-}-${pkgver}
|
|
|
|
python3 -m installer --destdir=${pkgdir} dist/*.whl
|
|
}
|