python-sphinxcontrib-devhelp/PKGBUILD

30 lines
1019 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=python-sphinxcontrib-devhelp
pkgver=2.0.0
pkgrel=1
pkgdesc="Sphinx extension which outputs Devhelp document"
arch=('x86_64')
url="https://github.com/sphinx-doc/sphinxcontrib-devhelp"
license=('BSD-2-Clause')
depends=('python')
makedepends=('python-build' 'python-flit-core' 'python-installer')
source=(https://github.com/sphinx-doc/sphinxcontrib-devhelp/archive/${pkgver}/${pkgname#*-}-${pkgver}.tar.gz)
sha256sums=(e650ce2bde1204477df2f428757e14aa85735bd6a40517645eba55730262b8e8)
build() {
cd ${pkgname#*-}-${pkgver}
python3 -m build --wheel --skip-dependency-check --no-isolation
}
package() {
cd ${pkgname#*-}-${pkgver}
python3 -m installer --destdir=${pkgdir} dist/*.whl
}