python-sphinxcontrib-serial.../PKGBUILD

30 lines
1.0 KiB
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=python-sphinxcontrib-serializinghtml
pkgver=2.0.0
pkgrel=1
pkgdesc="Sphinx extension which outputs "serialized" HTML files (json and pickle)"
arch=('x86_64')
url="https://github.com/sphinx-doc/sphinxcontrib-serializinghtml"
license=('BSD-2-Clause')
depends=('python')
makedepends=('python-build' 'python-flit-core' 'python-installer')
source=(https://github.com/sphinx-doc/sphinxcontrib-serializinghtml/archive/${pkgver}/${pkgname#*-}-${pkgver}.tar.gz)
sha256sums=(f418c9f2e93c2e732c5232b570c95e73b6b5c8dd54190f3645e96fb565ea272f)
build() {
cd ${pkgname#*-}-${pkgver}
python3 -m build --wheel --skip-dependency-check --no-isolation
}
package() {
cd ${pkgname#*-}-${pkgver}
python3 -m installer --destdir=${pkgdir} dist/*.whl
}