160 lines
8.7 KiB
Diff
160 lines
8.7 KiB
Diff
diff -Nuar Python-3.13.0.orig/configure Python-3.13.0/configure
|
|
--- Python-3.13.0.orig/configure 2024-10-07 13:02:14.000000000 +0800
|
|
+++ Python-3.13.0/configure 2024-11-02 23:08:48.750226902 +0800
|
|
@@ -9561,7 +9561,7 @@
|
|
fi
|
|
as_fn_append LINKFORSHARED " --preload-file=\$(WASM_ASSETS_DIR)"
|
|
WASM_ASSETS_DIR=".\$(prefix)"
|
|
- WASM_STDLIB="\$(WASM_ASSETS_DIR)/local/lib/python\$(VERSION)/os.py"
|
|
+ WASM_STDLIB="\$(WASM_ASSETS_DIR)/local/lib64/python\$(VERSION)/os.py"
|
|
WASM_LINKFORSHARED_DEBUG="-gsource-map --emit-symbol-map"
|
|
;; #(
|
|
node*) :
|
|
diff -Nuar Python-3.13.0.orig/configure.ac Python-3.13.0/configure.ac
|
|
--- Python-3.13.0.orig/configure.ac 2024-10-07 13:02:14.000000000 +0800
|
|
+++ Python-3.13.0/configure.ac 2024-11-02 23:09:06.590226834 +0800
|
|
@@ -2410,7 +2410,7 @@
|
|
AS_VAR_IF([ac_sys_emscripten_target], [browser-debug], [wasm_debug=yes])
|
|
AS_VAR_APPEND([LINKFORSHARED], [" --preload-file=\$(WASM_ASSETS_DIR)"])
|
|
WASM_ASSETS_DIR=".\$(prefix)"
|
|
- WASM_STDLIB="\$(WASM_ASSETS_DIR)/local/lib/python\$(VERSION)/os.py"
|
|
+ WASM_STDLIB="\$(WASM_ASSETS_DIR)/local/lib64/python\$(VERSION)/os.py"
|
|
dnl separate-dwarf does not seem to work in Chrome DevTools Support.
|
|
WASM_LINKFORSHARED_DEBUG="-gsource-map --emit-symbol-map"
|
|
],
|
|
diff -Nuar Python-3.13.0.orig/Lib/pydoc_data/topics.py Python-3.13.0/Lib/pydoc_data/topics.py
|
|
--- Python-3.13.0.orig/Lib/pydoc_data/topics.py 2024-10-07 13:02:14.000000000 +0800
|
|
+++ Python-3.13.0/Lib/pydoc_data/topics.py 2024-11-02 23:09:58.916226634 +0800
|
|
@@ -15874,7 +15874,7 @@
|
|
'\'sys\' (built-in)>". If loaded from a file, they are '
|
|
'written as\n'
|
|
'"<module \'os\' from '
|
|
- '\'/usr/local/lib/pythonX.Y/os.pyc\'>".\n',
|
|
+ '\'/usr/local/lib64/pythonX.Y/os.pyc\'>".\n',
|
|
'typesseq': 'Sequence Types — "list", "tuple", "range"\n'
|
|
'*****************************************\n'
|
|
'\n'
|
|
diff -Nuar Python-3.13.0.orig/Lib/site.py Python-3.13.0/Lib/site.py
|
|
--- Python-3.13.0.orig/Lib/site.py 2024-10-07 13:02:14.000000000 +0800
|
|
+++ Python-3.13.0/Lib/site.py 2024-11-02 23:11:19.949226325 +0800
|
|
@@ -324,9 +324,9 @@
|
|
return f'{userbase}\\{implementation}{ver_nodot}\\site-packages'
|
|
|
|
if sys.platform == 'darwin' and sys._framework:
|
|
- return f'{userbase}/lib/{implementation_lower}/site-packages'
|
|
+ return f'{userbase}/lib64/{implementation_lower}/site-packages'
|
|
|
|
- return f'{userbase}/lib/python{version[0]}.{version[1]}{abi_thread}/site-packages'
|
|
+ return f'{userbase}/lib64/python{version[0]}.{version[1]}{abi_thread}/site-packages'
|
|
|
|
|
|
def getuserbase():
|
|
diff -Nuar Python-3.13.0.orig/Lib/sysconfig/__init__.py Python-3.13.0/Lib/sysconfig/__init__.py
|
|
--- Python-3.13.0.orig/Lib/sysconfig/__init__.py 2024-10-07 13:02:14.000000000 +0800
|
|
+++ Python-3.13.0/Lib/sysconfig/__init__.py 2024-11-02 23:22:55.105223673 +0800
|
|
@@ -29,7 +29,7 @@
|
|
'posix_prefix': {
|
|
'stdlib': '{installed_base}/{platlibdir}/{implementation_lower}{py_version_short}{abi_thread}',
|
|
'platstdlib': '{platbase}/{platlibdir}/{implementation_lower}{py_version_short}{abi_thread}',
|
|
- 'purelib': '{base}/lib/{implementation_lower}{py_version_short}{abi_thread}/site-packages',
|
|
+ 'purelib': '{base}/lib64/{implementation_lower}{py_version_short}{abi_thread}/site-packages',
|
|
'platlib': '{platbase}/{platlibdir}/{implementation_lower}{py_version_short}{abi_thread}/site-packages',
|
|
'include':
|
|
'{installed_base}/include/{implementation_lower}{py_version_short}{abiflags}',
|
|
@@ -39,10 +39,10 @@
|
|
'data': '{base}',
|
|
},
|
|
'posix_home': {
|
|
- 'stdlib': '{installed_base}/lib/{implementation_lower}',
|
|
- 'platstdlib': '{base}/lib/{implementation_lower}',
|
|
- 'purelib': '{base}/lib/{implementation_lower}',
|
|
- 'platlib': '{base}/lib/{implementation_lower}',
|
|
+ 'stdlib': '{installed_base}/lib64/{implementation_lower}',
|
|
+ 'platstdlib': '{base}/lib64/{implementation_lower}',
|
|
+ 'purelib': '{base}/lib64/{implementation_lower}',
|
|
+ 'platlib': '{base}/lib64/{implementation_lower}',
|
|
'include': '{installed_base}/include/{implementation_lower}',
|
|
'platinclude': '{installed_base}/include/{implementation_lower}',
|
|
'scripts': '{base}/bin',
|
|
@@ -79,7 +79,7 @@
|
|
'posix_venv': {
|
|
'stdlib': '{installed_base}/{platlibdir}/{implementation_lower}{py_version_short}{abi_thread}',
|
|
'platstdlib': '{platbase}/{platlibdir}/{implementation_lower}{py_version_short}{abi_thread}',
|
|
- 'purelib': '{base}/lib/{implementation_lower}{py_version_short}{abi_thread}/site-packages',
|
|
+ 'purelib': '{base}/lib64/{implementation_lower}{py_version_short}{abi_thread}/site-packages',
|
|
'platlib': '{platbase}/{platlibdir}/{implementation_lower}{py_version_short}{abi_thread}/site-packages',
|
|
'include':
|
|
'{installed_base}/include/{implementation_lower}{py_version_short}{abiflags}',
|
|
@@ -150,17 +150,17 @@
|
|
'posix_user': {
|
|
'stdlib': '{userbase}/{platlibdir}/{implementation_lower}{py_version_short}{abi_thread}',
|
|
'platstdlib': '{userbase}/{platlibdir}/{implementation_lower}{py_version_short}{abi_thread}',
|
|
- 'purelib': '{userbase}/lib/{implementation_lower}{py_version_short}{abi_thread}/site-packages',
|
|
- 'platlib': '{userbase}/lib/{implementation_lower}{py_version_short}{abi_thread}/site-packages',
|
|
+ 'purelib': '{userbase}/lib64/{implementation_lower}{py_version_short}{abi_thread}/site-packages',
|
|
+ 'platlib': '{userbase}/lib64/{implementation_lower}{py_version_short}{abi_thread}/site-packages',
|
|
'include': '{userbase}/include/{implementation_lower}{py_version_short}{abi_thread}',
|
|
'scripts': '{userbase}/bin',
|
|
'data': '{userbase}',
|
|
},
|
|
'osx_framework_user': {
|
|
- 'stdlib': '{userbase}/lib/{implementation_lower}',
|
|
- 'platstdlib': '{userbase}/lib/{implementation_lower}',
|
|
- 'purelib': '{userbase}/lib/{implementation_lower}/site-packages',
|
|
- 'platlib': '{userbase}/lib/{implementation_lower}/site-packages',
|
|
+ 'stdlib': '{userbase}/lib64/{implementation_lower}',
|
|
+ 'platstdlib': '{userbase}/lib64/{implementation_lower}',
|
|
+ 'purelib': '{userbase}/lib64/{implementation_lower}/site-packages',
|
|
+ 'platlib': '{userbase}/lib64/{implementation_lower}/site-packages',
|
|
'include': '{userbase}/include/{implementation_lower}{py_version_short}',
|
|
'scripts': '{userbase}/bin',
|
|
'data': '{userbase}',
|
|
diff -Nuar Python-3.13.0.orig/Makefile.pre.in Python-3.13.0/Makefile.pre.in
|
|
--- Python-3.13.0.orig/Makefile.pre.in 2024-10-07 13:02:14.000000000 +0800
|
|
+++ Python-3.13.0/Makefile.pre.in 2024-11-02 23:18:05.206224779 +0800
|
|
@@ -258,7 +258,7 @@
|
|
|
|
# assets for Emscripten browser builds
|
|
WASM_ASSETS_DIR=.$(prefix)
|
|
-WASM_STDLIB=$(WASM_ASSETS_DIR)/lib/python$(VERSION)/os.py
|
|
+WASM_STDLIB=$(WASM_ASSETS_DIR)/lib64/python$(VERSION)/os.py
|
|
|
|
# Files and directories to be distributed
|
|
CONFIGFILES= configure configure.ac acconfig.h pyconfig.h.in Makefile.pre.in
|
|
diff -Nuar Python-3.13.0.orig/Misc/HISTORY Python-3.13.0/Misc/HISTORY
|
|
--- Python-3.13.0.orig/Misc/HISTORY 2024-10-07 13:02:14.000000000 +0800
|
|
+++ Python-3.13.0/Misc/HISTORY 2024-11-02 23:18:34.919224666 +0800
|
|
@@ -30361,7 +30361,7 @@
|
|
|
|
- The universal makefile Misc/Makefile.pre.in now features an
|
|
"install" target. By default, installed shared libraries go into
|
|
-$exec_prefix/lib/python$VERSION/site-packages/.
|
|
+$exec_prefix/lib64/python$VERSION/site-packages/.
|
|
|
|
- The install-sh script is installed with the other configuration
|
|
specific files (in the config/ subdirectory).
|
|
diff -Nuar Python-3.13.0.orig/Misc/python-config.sh.in Python-3.13.0/Misc/python-config.sh.in
|
|
--- Python-3.13.0.orig/Misc/python-config.sh.in 2024-10-07 13:02:14.000000000 +0800
|
|
+++ Python-3.13.0/Misc/python-config.sh.in 2024-11-02 23:19:20.514224492 +0800
|
|
@@ -54,7 +54,7 @@
|
|
OPT="@OPT@"
|
|
PY_ENABLE_SHARED="@PY_ENABLE_SHARED@"
|
|
LDVERSION="@LDVERSION@"
|
|
-LIBDEST=${prefix_real}/lib/python${VERSION}
|
|
+LIBDEST=${prefix_real}/lib64/python${VERSION}
|
|
LIBPL=$(echo "@LIBPL@" | sed "s#$prefix#$prefix_real#")
|
|
SO="@EXT_SUFFIX@"
|
|
PYTHONFRAMEWORK="@PYTHONFRAMEWORK@"
|
|
diff -Nuar Python-3.13.0.orig/Python/initconfig.c Python-3.13.0/Python/initconfig.c
|
|
--- Python-3.13.0.orig/Python/initconfig.c 2024-10-07 13:02:14.000000000 +0800
|
|
+++ Python-3.13.0/Python/initconfig.c 2024-11-02 23:19:56.102224356 +0800
|
|
@@ -303,7 +303,7 @@
|
|
#if defined(MS_WINDOWS)
|
|
# define PYTHONHOMEHELP "<prefix>\\python{major}{minor}"
|
|
#else
|
|
-# define PYTHONHOMEHELP "<prefix>/lib/pythonX.X"
|
|
+# define PYTHONHOMEHELP "<prefix>/lib64/pythonX.X"
|
|
#endif
|
|
|
|
|