re2c/PKGBUILD
2024-11-16 23:44:44 +08:00

37 lines
884 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=re2c
pkgver=3.1
pkgrel=1
pkgdesc="A tool for generating C-based recognizers from regular expressions"
arch=('x86_64')
url="https://re2c.org"
license=('public domain')
depends=('gcc-libs')
source=(https://github.com/skvadrik/re2c/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz)
sha256sums=(087c44de0400fb15caafde09fd72edc7381e688a35ef505ee65e0e3d2fac688b)
prepare() {
cd ${pkgname}-${pkgver}
sh autogen.sh
}
build() {
cd ${pkgname}-${pkgver}
${CONFIGURE}
make
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
}