41 lines
1.2 KiB
Bash
41 lines
1.2 KiB
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=ruby
|
|
pkgver=3.3.0
|
|
pkgrel=1
|
|
pkgdesc="An object-oriented language for quick and easy programming"
|
|
arch=('x86_64')
|
|
url="https://www.ruby-lang.org/en"
|
|
license=('BSD' 'custom')
|
|
depends=('gdbm' 'openssl' 'libffi' 'libyaml' 'libxcrypt' 'gmp' 'zlib')
|
|
options=('!emptydirs' '!lto')
|
|
source=(https://cache.ruby-lang.org/pub/ruby/${pkgver/%.*}/${pkgname}-${pkgver}.tar.xz)
|
|
sha256sums=(676b65a36e637e90f982b57b059189b3276b9045034dcd186a7e9078847b975b)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
export CFLAGS="${CFLAGS/_FORTIFY_SOURCE=3/_FORTIFY_SOURCE=2}"
|
|
export CXXFLAGS="${CXXFLAGS/_FORTIFY_SOURCE=3/_FORTIFY_SOURCE=2}"
|
|
|
|
${CONFIGURE} \
|
|
--disable-rpath \
|
|
--enable-shared \
|
|
--without-valgrind \
|
|
--without-baseruby \
|
|
ac_cv_func_qsort_r=no \
|
|
--docdir=/usr/share/doc/${pkgname}-${pkgver}
|
|
|
|
make capi
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|