sessreg/PKGBUILD
2024-04-15 22:54:23 +08:00

36 lines
940 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=sessreg
pkgver=1.1.3
pkgrel=1
pkgdesc="Register X sessions in system utmp/utmpx databases"
arch=('x86_64')
url="https://xorg.freedesktop.org/"
license=('custom')
groups=('xorg-apps' 'xorg')
depends=('glibc')
makedepends=('util-macros' 'xorgproto')
source=(https://www.x.org/pub/individual/app/${pkgname}-${pkgver}.tar.xz)
sha256sums=(022acd5de8077dddc4f919961f79e102ecd5f3228a333681af5cd0e7344facc2)
build() {
cd ${pkgname}-${pkgver}
${CONFIGURE} \
--sysconfdir=/etc \
--localstatedir=/var \
--disable-static
make
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
}