shared-mime-info/PKGBUILD
2024-04-17 13:28:31 +08:00

46 lines
1.5 KiB
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=shared-mime-info
pkgver=2.4
pkgrel=1
pkgdesc="Freedesktop.org Shared MIME Info"
arch=('x86_64')
url="https://www.freedesktop.org/wiki/Specifications/shared-mime-info-spec/"
license=('GPL2')
depends=('libxml2' 'glib2' 'glibc' 'gcc-libs')
makedepends=('gettext' 'xmlto' 'docbook-xsl' 'meson')
options=('!makeflags')
install=${pkgname}.install
source=(https://gitlab.freedesktop.org/xdg/shared-mime-info/-/archive/${pkgver}/${pkgname}-${pkgver}.tar.gz
https://anduin.linuxfromscratch.org/BLFS/xdgmime/xdgmime.tar.xz
update-mime-database.hook)
sha256sums=(531291d0387eb94e16e775d7e73788d06d2b2fdd8cd2ac6b6b15287593b6a2de
9020f04a0bb841e3cd9c6c5f60a75087eb21def5b17a651ee53f99524873cb18
f08efbcbac9d2bd18a805b8dcf3ed06d7763b97eca5935aa64d65593774b6501)
build() {
cd ${pkgname}-${pkgver}
CFLAGS= make -C ${srcdir}/xdgmime
meson setup build \
--prefix=/usr \
--buildtype=release \
-Dupdate-mimedb=false \
-Dxdgmime-path=${srcdir}/xdgmime
meson compile -C build
}
package() {
cd ${pkgname}-${pkgver}
meson install -C build --destdir ${pkgdir}
install -Dm644 ${srcdir}/update-mime-database.hook ${pkgdir}/usr/share/libalpm/hooks/30-update-mime-database.hook
}