spirv-tools/PKGBUILD
2024-04-15 22:13:33 +08:00

39 lines
1.2 KiB
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=spirv-tools
pkgver=1.3.280.0
pkgrel=1
pkgdesc="API and commands for processing SPIR-V modules"
arch=('x86_64')
url="https://www.khronos.org/vulkan/"
license=('Apache-2.0')
depends=('gcc' 'bash' 'spirv-headers')
makedepends=('cmake' 'ninja' 'python')
source=(https://github.com/KhronosGroup/SPIRV-Tools/archive/refs/tags/vulkan-sdk-${pkgver}/SPIRV-Tools-${pkgver}.tar.gz)
sha256sums=(703c772a850fa7fbe57a2f8dc99b4c1422a59fa5ff098a80c8ce12fcdf6a2613)
build() {
cd SPIRV-Tools-vulkan-sdk-${pkgver}
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib64 \
-DCMAKE_BUILD_TYPE=Release \
-DSPIRV_WERROR=OFF \
-DBUILD_SHARED_LIBS=ON \
-DSPIRV_TOOLS_BUILD_STATIC=OFF \
-DSPIRV-Headers_SOURCE_DIR=/usr \
-G Ninja -Bbuild
ninja -C build
}
package() {
cd SPIRV-Tools-vulkan-sdk-${pkgver}
DESTDIR=${pkgdir} ninja -C build install
}