41 lines
1.2 KiB
Bash
41 lines
1.2 KiB
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=texinfo
|
|
pkgver=7.1.1
|
|
pkgrel=1
|
|
pkgdesc="GNU documentation system for on-line information and printed output"
|
|
arch=('x86_64')
|
|
url="https://www.gnu.org/software/texinfo/"
|
|
license=('GPL3')
|
|
groups=('base-devel')
|
|
depends=('ncurses' 'gzip' 'perl' 'bash')
|
|
source=(https://ftp.gnu.org/gnu/${pkgname}/${pkgname}-${pkgver}.tar.xz
|
|
texinfo-install.hook
|
|
texinfo-remove.hook)
|
|
sha256sums=(31ae37e46283529432b61bee1ce01ed0090d599e606fc6a29dca1f77c76a6c82
|
|
beb0ff50bd8e8ca1d6e1c01e6a50352f9d25937c62822cf767a7b3d8f7374a9d
|
|
913ca8aac84386399b0a83ed0f6b04b5e6322da62f5c1d7ed31e1050ed37c1a9)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE}
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
make DESTDIR=${pkgdir} TEXMF=/usr/share/texmf install-tex
|
|
|
|
install -dm755 ${pkgdir}/usr/share/libalpm/hooks/
|
|
install -m644 ${srcdir}/texinfo-{install,remove}.hook ${pkgdir}/usr/share/libalpm/hooks/
|
|
|
|
}
|