35 lines
988 B
Bash
35 lines
988 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=wayland-protocols
|
|
pkgver=1.34
|
|
pkgrel=1
|
|
pkgdesc="Specifications of extended Wayland protocols"
|
|
arch=('x86_64')
|
|
url='https://wayland.freedesktop.org/'
|
|
license=('MIT')
|
|
depends=('wayland')
|
|
makedepends=('meson' 'ninja')
|
|
source=(https://gitlab.freedesktop.org/wayland/wayland-protocols/-/releases/${pkgver}/downloads/${pkgname}-${pkgver}.tar.xz)
|
|
sha256sums=(c59b27cacd85f60baf4ee5f80df5c0d15760ead6a2432b00ab7e2e0574dcafeb)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
meson setup build \
|
|
--prefix=/usr \
|
|
--buildtype=release \
|
|
-Dlibdir=/usr/lib64
|
|
|
|
meson compile -C build
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
meson install -C build --destdir ${pkgdir}
|
|
}
|