xauth/PKGBUILD
2024-04-15 22:58:50 +08:00

36 lines
973 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=xauth
pkgver=1.1.3
pkgrel=1
pkgdesc="X.Org authorization settings program"
arch=('x86_64')
url="https://gitlab.freedesktop.org/xorg/app/xauth"
license=('MIT-open-group')
groups=('xorg-apps' 'xorg')
depends=('libxmu' 'libxau' 'libxext' 'libx11' 'glibc')
makedepends=('util-macros')
source=(https://www.x.org/pub/individual/app/${pkgname}-${pkgver}.tar.xz)
sha256sums=(e7075498bae332f917f01d660f9b940c0752b2556a8da61ccb62a44d0ffe9d33)
build() {
cd ${pkgname}-${pkgver}
${CONFIGURE} \
--sysconfdir=/etc \
--localstatedir=/var \
--disable-static
make
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
}