35 lines
956 B
Bash
35 lines
956 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=xcb-util-cursor
|
|
pkgver=0.1.5
|
|
pkgrel=1
|
|
pkgdesc="XCB cursor library"
|
|
arch=('x86_64')
|
|
url="https://cgit.freedesktop.org/xcb/util-cursor"
|
|
license=('custom:MIT')
|
|
depends=('libxcb' 'xcb-util-renderutil' 'xcb-util-image' 'glibc')
|
|
makedepends=('xorgproto')
|
|
source=(https://xorg.freedesktop.org/archive/individual/lib/${pkgname}-${pkgver}.tar.xz)
|
|
sha256sums=(0caf99b0d60970f81ce41c7ba694e5eaaf833227bb2cbcdb2f6dc9666a663c57)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--disable-static
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|