35 lines
903 B
Bash
35 lines
903 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=xcb-util
|
|
pkgver=0.4.1
|
|
pkgrel=1
|
|
pkgdesc="Utility libraries for XC Binding"
|
|
arch=('x86_64')
|
|
url="https://xcb.freedesktop.org"
|
|
license=('custom')
|
|
depends=('libxcb>=1.7')
|
|
makedepends=('gperf' 'util-macros' 'xorgproto')
|
|
source=(https://xcb.freedesktop.org/dist/${pkgname}-${pkgver}.tar.xz)
|
|
sha256sums=(5abe3bbbd8e54f0fa3ec945291b7e8fa8cfd3cccc43718f8758430f94126e512)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--disable-static
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|