xdpyinfo/PKGBUILD
2024-04-15 23:04:07 +08:00

36 lines
1001 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=xdpyinfo
pkgver=1.3.4
pkgrel=1
pkgdesc="Display information utility for X"
arch=('x86_64')
url="https://xorg.freedesktop.org/"
license=('custom')
groups=('xorg-apps' 'xorg')
depends=('libx11' 'libxext' 'libxtst' 'libxxf86vm' 'libxrender' 'libxcomposite' 'libxinerama')
makedepends=('util-macros' 'xorgproto')
source=(https://www.x.org/pub/individual/app/${pkgname}-${pkgver}.tar.xz)
sha256sums=(a8ada581dbd7266440d7c3794fa89edf6b99b8857fc2e8c31042684f3af4822b)
build() {
cd ${pkgname}-${pkgver}
${CONFIGURE} \
--sysconfdir=/etc \
--localstatedir=/var \
--disable-static
make
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
}