xdriinfo/PKGBUILD
2024-04-16 00:22:12 +08:00

36 lines
945 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=xdriinfo
pkgver=1.0.7
pkgrel=1
pkgdesc="Query configuration information of DRI drivers"
arch=('x86_64')
url="https://xorg.freedesktop.org/"
license=('custom')
groups=('xorg-apps' 'xorg')
depends=('mesa' 'libx11')
makedepends=('util-macros' 'xorgproto')
source=(https://www.x.org/pub/individual/app/${pkgname}-${pkgver}.tar.xz)
sha256sums=(dd838bae9d2b19ddd71fe6d30ed33abc7c85e19d223e79d35600db3fa44bf734)
build() {
cd ${pkgname}-${pkgver}
${CONFIGURE} \
--sysconfdir=/etc \
--localstatedir=/var \
--disable-static
make
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
}