36 lines
944 B
Bash
36 lines
944 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=xev
|
|
pkgver=1.2.6
|
|
pkgrel=1
|
|
pkgdesc="Print contents of X events"
|
|
arch=('x86_64')
|
|
url="https://gitlab.freedesktop.org/xorg/app/xev"
|
|
license=('MIT')
|
|
groups=('xorg-apps' 'xorg')
|
|
depends=('glibc' 'libx11' 'libxrandr')
|
|
makedepends=('util-macros' 'xorgproto')
|
|
source=(https://www.x.org/pub/individual/app/${pkgname}-${pkgver}.tar.xz)
|
|
sha256sums=(61e1c5e008ac9973aca7cdddf36e9df7410e77083b030eb04f4dc737c51807d7)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--disable-static
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|