36 lines
986 B
Bash
36 lines
986 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=xf86-input-evdev
|
|
pkgver=2.10.6
|
|
pkgrel=1
|
|
pkgdesc="X.org evdev input driver"
|
|
arch=('x86_64')
|
|
url="https://xorg.freedesktop.org/"
|
|
license=('HPND-sell-variant AND MIT')
|
|
groups=('xorg-drivers')
|
|
depends=('systemd' 'mtdev' 'libevdev' 'glibc')
|
|
makedepends=('xorg-server' 'util-macros' 'xorgproto')
|
|
source=(https://www.x.org/pub/individual/driver/${pkgname}-${pkgver}.tar.bz2)
|
|
sha256sums=(8726073e81861bc7b2321e76272cbdbd33c7e1a121535a9827977265b9033ec0)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--disable-static
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|