xf86-input-libinput/PKGBUILD

36 lines
990 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=xf86-input-libinput
pkgver=1.4.0
pkgrel=1
pkgdesc="Generic input driver for the X.Org server based on libinput"
arch=('x86_64')
url="http://xorg.freedesktop.org"
license=('custom:MIT')
groups=('xorg-drivers')
depends=('libinput' 'glibc')
makedepends=('xorg-server' 'libxi' 'libx11' 'xorgproto')
source=(https://www.x.org/pub/individual/driver/${pkgname}-${pkgver}.tar.xz)
sha256sums=(3a3d14cd895dc75b59ae2783b888031956a0bac7a1eff16d240dbb9d5df3e398)
build() {
cd ${pkgname}-${pkgver}
${CONFIGURE} \
--sysconfdir=/etc \
--localstatedir=/var \
--disable-static
make
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
}