36 lines
968 B
Bash
36 lines
968 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=xf86-input-synaptics
|
|
pkgver=1.9.2
|
|
pkgrel=1
|
|
pkgdesc="Synaptics driver for notebook touchpads"
|
|
arch=('x86_64')
|
|
url="https://xorg.freedesktop.org/"
|
|
license=('MIT')
|
|
groups=('xorg-drivers')
|
|
depends=('libxtst' 'libevdev')
|
|
makedepends=('xorg-server' 'libxi' 'libx11' 'xorgproto')
|
|
source=(https://www.x.org/pub/individual/driver/${pkgname}-${pkgver}.tar.xz)
|
|
sha256sums=(b8fa4aab913fc63754bbd6439e020658c412743a055201ddf212760593962c38)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--disable-static
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|