36 lines
961 B
Bash
36 lines
961 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=xkbcomp
|
|
pkgver=1.4.7
|
|
pkgrel=1
|
|
pkgdesc="X Keyboard description compiler"
|
|
arch=('x86_64')
|
|
url="https://gitlab.freedesktop.org/xorg/app/xkbcomp"
|
|
license=('LicenseRef-xkbcomp')
|
|
depends=('libxkbfile' 'libx11' 'glibc')
|
|
groups=('xorg-apps' 'xorg')
|
|
makedepends=('util-macros')
|
|
source=(https://www.x.org/pub/individual/app/${pkgname}-${pkgver}.tar.xz)
|
|
sha256sums=(0a288114e5f44e31987042c79aecff1ffad53a8154b8ec971c24a69a80f81f77)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--disable-static
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|