35 lines
912 B
Bash
35 lines
912 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=xmessage
|
|
pkgver=1.0.7
|
|
pkgrel=1
|
|
pkgdesc="Display a message or query in a window"
|
|
arch=('x86_64')
|
|
url="https://xorg.freedesktop.org/"
|
|
license=('X11')
|
|
depends=('glibc' 'libx11' 'libxaw' 'libxt')
|
|
makedepends=('util-macros')
|
|
source=(https://www.x.org/pub/individual/app/${pkgname}-${pkgver}.tar.xz)
|
|
sha256sums=(703fccb7a0b772d61d7e603c189b9739866aa97ba985c727275420f829a30356)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--disable-static
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|