36 lines
922 B
Bash
36 lines
922 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=xrefresh
|
|
pkgver=1.1.0
|
|
pkgrel=1
|
|
pkgdesc="Refresh all or part of an X screen"
|
|
arch=('x86_64')
|
|
url="https://xorg.freedesktop.org/"
|
|
license=('custom')
|
|
groups=('xorg-apps' 'xorg')
|
|
depends=('glibc' 'libx11')
|
|
makedepends=('util-macros')
|
|
source=(https://www.x.org/pub/individual/app/${pkgname}-${pkgver}.tar.xz)
|
|
sha256sums=(29ed592d5ece35a3029004d8c46f3002f92970870a96c11e38baf7f1122b8b5f)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--sysconfdir=/etc \
|
|
--localstatedir=/var \
|
|
--disable-static
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|