34 lines
888 B
Bash
34 lines
888 B
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=xtrans
|
|
pkgver=1.5.0
|
|
pkgrel=1
|
|
pkgdesc="X transport library"
|
|
arch=('x86_64')
|
|
url="https://xorg.freedesktop.org/"
|
|
license=('custom')
|
|
makedepends=('util-macros' 'xorgproto')
|
|
options=('!emptydirs')
|
|
source=(https://www.x.org/pub/individual/lib/${pkgname}-${pkgver}.tar.xz)
|
|
sha256sums=(1ba4b703696bfddbf40bacf25bce4e3efb2a0088878f017a50e9884b0c8fb1bd)
|
|
|
|
build() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
${CONFIGURE} \
|
|
--disable-static \
|
|
--docdir=/usr/share/doc/${pkgname}-${pkgver}
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}-${pkgver}
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|