xwd/PKGBUILD
2024-04-16 17:44:02 +08:00

36 lines
941 B
Bash

# This is an example PKGBUILD file. Use this as a start to creating your own,
# and remove these comments. For more information, see 'man PKGBUILD'.
# NOTE: Please fill out the license field for your package! If it is unknown,
# then please put 'unknown'.
# Maintainer: Future Linux Team <future_linux@163.com>
pkgname=xwd
pkgver=1.0.9
pkgrel=1
pkgdesc="X Window System image dumping utility"
arch=('x86_64')
url="https://xorg.freedesktop.org/"
license=('custom')
groups=('xorg-apps' 'xorg')
depends=('libxkbfile' 'libx11' 'glibc')
makedepends=('util-macros' 'libxt')
source=(https://www.x.org/pub/individual/app/${pkgname}-${pkgver}.tar.xz)
sha256sums=(dc121b84947eb4a3d1131bff1e9844cfa2124d95b47b35f9932340fa931fbd3f)
build() {
cd ${pkgname}-${pkgver}
${CONFIGURE} \
--sysconfdir=/etc \
--localstatedir=/var \
--disable-static
make
}
package() {
cd ${pkgname}-${pkgver}
make DESTDIR=${pkgdir} install
}