48 lines
1.7 KiB
Bash
48 lines
1.7 KiB
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Your Name <youremail@domain.com>
|
|
pkgname=ypkg
|
|
pkgver=33
|
|
pkgrel=2
|
|
pkgdesc="Modern, declarative, structured build format"
|
|
arch=('x86_64')
|
|
url="https://github.com/getsolus/ypkg"
|
|
license=('GPL-3.0-or-later')
|
|
depends=('eopkg' 'python-xattr' 'python-pyyaml' 'python-ruamel_yaml' 'python-magic')
|
|
makedepends=('python-nuitka' 'patchelf' 'python-zstandard' 'tree' 'git')
|
|
source=(git+https://github.com/getsolus/ypkg.git#tag=v${pkgver})
|
|
sha256sums=(SKIP)
|
|
|
|
build() {
|
|
cd ${pkgname}
|
|
|
|
python3 setup.py build
|
|
|
|
time nuitka --onefile --include-module=dbm.gnu --show-scons --lto=yes --no-deployment-flag=self-execution --main=ypkg --main=ypkg-build --main=ypkg-install-deps --main=ypkg-gen-history --include-package-data=ypkg2 --jobs=6
|
|
}
|
|
|
|
package() {
|
|
cd ${pkgname}
|
|
|
|
python3 setup.py install --root=${pkgdir}
|
|
|
|
mv ${pkgdir}/usr/bin/ypkg ${pkgdir}/usr/bin/ypkg.py
|
|
|
|
install -Dm0755 ypkg.bin -t ${pkgdir}/usr/bin/
|
|
ln -svf ypkg.bin ${pkgdir}/usr/bin/ypkg
|
|
|
|
# Create symlinks for the other binaries
|
|
for b in ypkg-build ypkg-install-deps ypkg-gen-history
|
|
do
|
|
mv ${pkgdir}/usr/bin/${b} ${pkgdir}/usr/bin/${b}.py
|
|
# this can be used to switch the used version between the nuitka .bin ones and the pure .py ones
|
|
#ln -srvf ${pkgdir}/usr/bin/$b.py ${pkgdir}/usr/bin/$b
|
|
ln -svf ypkg ${pkgdir}/usr/bin/${b}
|
|
done
|
|
# show the current symlink targets for convenience
|
|
tree -P 'y*' ${pkgdir}/usr/bin/
|
|
}
|