44 lines
1.1 KiB
Bash
44 lines
1.1 KiB
Bash
# This is an example PKGBUILD file. Use this as a start to creating your own,
|
|
# and remove these comments. For more information, see 'man PKGBUILD'.
|
|
# NOTE: Please fill out the license field for your package! If it is unknown,
|
|
# then please put 'unknown'.
|
|
|
|
# Maintainer: Future Linux Team <future_linux@163.com>
|
|
pkgname=future-install-scripts
|
|
pkgver=29
|
|
pkgrel=1
|
|
pkgdesc="Scripts to aid in installing Future Linux"
|
|
arch=('x86_64')
|
|
url="https://gitlab.archlinux.org/archlinux/arch-install-scripts"
|
|
license=('GPL-2.0-only')
|
|
depends=('gawk' 'bash' 'coreutils' 'grep' 'pacman' 'util-linux')
|
|
makedepends=('git' 'python-asciidoc')
|
|
source=(git+https://gitlab.archlinux.org/archlinux/arch-install-scripts.git#tag=v${pkgver}
|
|
b53d472be3.patch)
|
|
sha256sums=(SKIP
|
|
9236d6a4a0ba586f3c7184e7379b8e3e94548c365e65cd312983eb7e661ee673)
|
|
|
|
pkgver() {
|
|
cd arch-install-scripts
|
|
|
|
git describe | sed 's/^v//'
|
|
}
|
|
|
|
prepare() {
|
|
cd arch-install-scripts
|
|
|
|
git apply ${srcdir}/b53d472be3.patch
|
|
}
|
|
|
|
build() {
|
|
cd arch-install-scripts
|
|
|
|
make
|
|
}
|
|
|
|
package() {
|
|
cd arch-install-scripts
|
|
|
|
make DESTDIR=${pkgdir} install
|
|
}
|